J&P Cycles Technical Forums

Come participate in our American V-Twin and Metric motorcycle tech forums
Welcome to J&P Cycles Technical Forums Sign in | Join | Help
in Search
Latest post Tue, May 23 2017 9:06 PM by Ironhead. 6 replies.
Page 1 of 1 (7 items)
Sort Posts: Previous Next
  • Wed, May 17 2017 8:56 PM

    Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

    The person before me put LED turn signals on the front and rear of the bike. They light for running and braking but don't flash when using the turn signal. The wiring seems to be right. Is the problem most likely that the flasher module is bad? Could the LEDs not be drawing enough power for the flasher module to work? Is there an easy solve for this? Any help would be greatly appreciated.

  • Thu, May 18 2017 6:04 PM In reply to

    • Ironhead
    • Top 10 Contributor
      Male
    • Joined on Tue, Mar 21 2006
    • Near Sunset at Sunset Beach, O'ahu, HI Oct 23, 15
    • Posts 2,578
    • Moderator

    Re: Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

    dmaydesigner - first, welcome to the forums - what part of the country are you from?

    first, have they worked since you got the bike or were they not working when you bought it? 

    Is the flasher module a stock harley part or an aftermarket unit?

    Are there any brand names on the signal lights.  such as are they stock units with LED bulbs or a complete aftermarket unit?

    On the rear, is there two signal lights AND a tail light or just the two side lights?

    Just tring to figure out what mods the previous owner did

    The first tool out of the box should be the "book"  Geeked

  • Fri, May 19 2017 10:06 AM In reply to

    Re: Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

     probably needs a load equalizer, but like ironhead says, we'll need a little more info

     

  • Sat, May 20 2017 10:59 AM In reply to

    Re: Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

    Thanks - Its great everyone puts the effort into helping novices like me.

    The module is a stock original part. I think the lights are Kyuriakan but not sure. There is no name on them. The lights never flashed. There are two signal lights and a brake light in the rear and two bullet style signal lights off the forks in the front. Everything lights up when turned on but when you depress the signal switch the lights don't flash. You literally have to turn the lights on and off repeatedly to make them appear to flash. 

  • Tue, May 23 2017 6:59 AM In reply to

    Re: Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

    Should I just go back to standard bulbs?

  • Tue, May 23 2017 10:01 AM In reply to

    • FX
    • Top 10 Contributor
      Male
    • Joined on Sun, Mar 12 2006
    • Tonawanda NY
    • Posts 5,096
    • Moderator

    Re: Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

    dm, yes try standard bulbs if you don't want to buy a load equalizer. Have you replaced the flasher? Were the led's ever working?

    FX

    Don't force it, get a bigger hammer.

  • Tue, May 23 2017 9:06 PM In reply to

    • Ironhead
    • Top 10 Contributor
      Male
    • Joined on Tue, Mar 21 2006
    • Near Sunset at Sunset Beach, O'ahu, HI Oct 23, 15
    • Posts 2,578
    • Moderator

    Re: Turn Signal Issues - 1994 Sportster 1200 Standard XLH1200

    dm - if you can go back to standard bulbs for the price of 4 light bulbs, I would suggest doing that.  you would then be able to verify the system works when stock and go step by step back to the LEDs.

    Something I would suggest is you get a shop manual for your bike.  Besides directions on how to perform most jobs, even poor ones provide the proper torques and wiring diagrams (would be helpfull for this repair).

    I prefer the Clymer brand - J&P should have one for your '94

    The first tool out of the box should be the "book"  Geeked

Page 1 of 1 (7 items)