J&P Cycles Technical Forums

Come participate in our American V-Twin and Metric motorcycle tech forums
Welcome to J&P Cycles Technical Forums Sign in | Join | Help
in Search
Latest post Wed, Jun 28 2017 1:36 AM by dokarl9. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • Fri, Jun 16 2017 4:22 AM

    MY BIKE WONT START PLEASE HELP THIS OLD TIMER WILD BILL HERE

    My bike wont starte I nhave 883 hugger 2003 all the lights work but head light wont come on or dash lights showing neutral or or oil and no crank I chand relay and head lamp

    Nothing all lights and battery new just wont go in nutral or crank over even with cluth in gaged 

  • Fri, Jun 16 2017 4:24 AM In reply to

    Re: MY BIKE WONT START PLEASE HELP THIS OLD TIMER WILD BILL HERE

    ALSO CHANGED RELAY 

  • Fri, Jun 16 2017 5:34 AM In reply to

    • Ironhead
    • Top 10 Contributor
      Male
    • Joined on Tue, Mar 21 2006
    • Near Sunset at Sunset Beach, O'ahu, HI Oct 23, 15
    • Posts 2,587
    • Moderator

    Re: MY BIKE WONT START PLEASE HELP THIS OLD TIMER WILD BILL HERE

    Bill - first, welcome to the forums - what part of the country are you from?

    Has all this started immediately after changing the battery or was it working for a while on the new battery?

    Reason for asking is too often we see small problems that arise just after doing a small job and something didn't get hooked up again (or right).

    If not, it sounds like a job for your wiring diagram and a multi-meter. 

    The first tool out of the box should be the "book"  Geeked

  • Fri, Jun 16 2017 6:05 AM In reply to

    • FX
    • Top 10 Contributor
      Male
    • Joined on Sun, Mar 12 2006
    • Tonawanda NY
    • Posts 5,108
    • Moderator

    Re: MY BIKE WONT START PLEASE HELP THIS OLD TIMER WILD BILL HERE

    Bill, nice to have ya here. Exactly what is it doing when you hit the starter button? Like Ironhead says, check all that you recently did, especially wire connections. Make sure the 'kill switch' is in the 'run' position. If it's just clicking when you press the starter button, it could be a bad solenoid...With those lights & dash out, I would suspect wiring...

      I'm going to move this thread over to 'Sportster' in Harley Tech, where it should be Bill. More will see it to help you...

    FX

    Don't force it, get a bigger hammer.

  • Wed, Jun 28 2017 1:36 AM In reply to

    • dokarl9
    • Not Ranked
    • Joined on Mon, Apr 24 2017
    • Posts 11

    Re: MY BIKE WONT START PLEASE HELP THIS OLD TIMER WILD BILL HERE

    Check for dirty or loose connections. Clean them and use dielectric grease.

Page 1 of 1 (5 items)