J&P Cycles Technical Forums

Come participate in our American V-Twin and Metric motorcycle tech forums
Welcome to J&P Cycles Technical Forums Sign in | Join | Help
in Search
Latest post Tue, Apr 17 2018 8:53 PM by flstfi01jt. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • Mon, Apr 16 2018 9:55 PM

    2001 fatboy EFI pops/backfires on start-up

    2001 fatboy EFI pops/backfires on start-up,  Hard start,  Once running no issue.  I do have a power commander (old  school) way back from 01,  has  the serial port sync cable.  program is good.  Not sure if there is a issue with the idel/throttle cable binding.  feels free though. been sidelined for about a year so I have been on it in about a year.  Battery is good.  thoughts?  

    Filed under:
  • Tue, Apr 17 2018 6:12 AM In reply to

    • FX
    • Top 10 Contributor
      Male
    • Joined on Sun, Mar 12 2006
    • Tonawanda NY
    • Posts 5,174
    • Moderator

    Re: 2001 fatboy EFI pops/backfires on start-up

    If bike's been sitting for a year with old gas in it, replace it with new. Backfiring is usualy a sign of running lean, maybe dirty injectors...

    FX

    Don't force it, get a bigger hammer.

  • Tue, Apr 17 2018 9:59 AM In reply to

    Re: 2001 fatboy EFI pops/backfires on start-up

     could be old gas. if that doesn't cure it, i'd check the timing curve, if it's too advanced at low rpm it will give that symptom also

     

  • Tue, Apr 17 2018 8:49 PM In reply to

    Re: 2001 fatboy EFI pops/backfires on start-up

    Appreciate the feedback gents. I’m leanin towards the I jectotoy

  • Tue, Apr 17 2018 8:53 PM In reply to

    Re: 2001 fatboy EFI pops/backfires on start-up

    meant to say injectors

Page 1 of 1 (5 items)