J&P Cycles Technical Forums

Come participate in our American V-Twin and Metric motorcycle tech forums
Welcome to J&P Cycles Technical Forums Sign in | Join | Help
in Search
Latest post Thu, Aug 2 2018 11:02 AM by vincmm. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • Thu, Aug 2 2018 6:15 AM

    • vincmm
    • Not Ranked
    • Joined on Thu, Aug 2 2018
    • Posts 3

    New Air filter - Splugs , and my TC88 Ultra seems to have loss some power

    I recently picked up a '05 HD Ultra injected.... running rineharts and has dynojet tuner... going over it -- i noticed the HD stage 1 air cleaner neede replaced.  

    So ordered up a replacement filter (part# 400-0114)  through JPC along with a set of NGK plugs. 

    I used carb cleaner to clean up the Throttle body as it looked like was a lil neglectaed... got parts yesterday  - gapped plaugs to .041 and installed the air cleaner.   Went to start the bike, and I had to hit the start button like 3 times beofre it fired.  At first idled rough, but then leveled out. Assumed was from the cleaning the TB the day before.  

    I let run a bit, warmed it up and ran it down the road.   When I turned around I got on ot a bit and it fell on it face, then took off.  After that though it seemd to accelerate through the gears - seemed quiter than before (pipes) ...went to the other end of the road, turned around got on it again, didn;t fall on its face but just didn't feel like it was pulling as hard as before doing the above.... 

    During my lok over I noticed a muffler clamp was mispositioned which i think was a culprit for a pop when i would get on it from a stop -   

    Guessin gI'm loking to see if anyone has similar issues?    Now I have only had this bike for a week, and rode it like 3 times  so still a newbie to it.  

  • Thu, Aug 2 2018 6:30 AM In reply to

    • FX
    • Top 10 Contributor
      Male
    • Joined on Sun, Mar 12 2006
    • Tonawanda NY
    • Posts 5,206
    • Moderator

    Re: New Air filter - Splugs , and my TC88 Ultra seems to have loss some power

    Were the Rineharts recently installed? If so, you will probably have to re-map the Dynojet because of the different back-pressure. Also, if the Dynojet was set up with a dirty air filter, and you cleaned it, this my be causing it to run leaner...

    FX

    Don't force it, get a bigger hammer.

  • Thu, Aug 2 2018 7:24 AM In reply to

    • vincmm
    • Not Ranked
    • Joined on Thu, Aug 2 2018
    • Posts 3

    Re: New Air filter - Splugs , and my TC88 Ultra seems to have loss some power

    No rineharts and tunner came on the bike.  

    IDK when the it was tuned or how -  may have to run it again tonight and see if runs same as last night if so, talked to a shop yesterday that said they are set up to tune the dynojet tuner to check the map being used. 

  • Thu, Aug 2 2018 7:42 AM In reply to

    • FX
    • Top 10 Contributor
      Male
    • Joined on Sun, Mar 12 2006
    • Tonawanda NY
    • Posts 5,206
    • Moderator

    Re: New Air filter - Splugs , and my TC88 Ultra seems to have loss some power

    Yes, that's the best way to go with it vin. Then if there is still a problem we can take it from there knowing it's tuned right...

    FX

    Don't force it, get a bigger hammer.

  • Thu, Aug 2 2018 11:02 AM In reply to

    • vincmm
    • Not Ranked
    • Joined on Thu, Aug 2 2018
    • Posts 3

    Re: New Air filter - Splugs , and my TC88 Ultra seems to have loss some power

    will see what happens - i had plan on taking it in for fluid change and a good look over, might be just added to work list -  

Page 1 of 1 (5 items)