J&P Cycles Technical Forums

Come participate in our American V-Twin and Metric motorcycle tech forums
Welcome to J&P Cycles Technical Forums Sign in | Join | Help
in Search
Latest post Wed, Apr 25 2018 9:08 AM by sfranta. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • Wed, Apr 25 2018 2:49 AM

    • OSTank82
    • Not Ranked
    • Joined on Wed, Apr 25 2018
    • Posts 1

    07 efi won't start only pops out exhaust

    I have a 2007 96ci twin cam all stock motor, free flow air free flow exhaust, Thundermax Wave tuner (yes I have been in contact with Thundermax)  my compression is 160 psi for both, new fuel pump a year ago, new in tank high pressure fuel lines replaced, new intake seals, new BARO sensor, new battery, fresh fuel, new plugs.... I work on Harley's  all day and have exhausted all other ideas, have checked the normal stuff and gone threw the manuals so let's get passed all that, I'm looking for out of the norm ..

     

    she will crank no problem, but won't even try and fire only LOUD BANG like real loud out exhaust every once in a wile with little flame.. plugs are WAY OVER SATURATED with fuel, not suty just soaked......

     

    yes i I tried plugging stock ecm won't even do the loud pop, have tried several different maps working with Thundermax techs, ran diagnostics on there unit it's working proper... me and my  colleagues  are baffled 

  • Wed, Apr 25 2018 5:26 AM In reply to

    • Ironhead
    • Top 10 Contributor
      Male
    • Joined on Tue, Mar 21 2006
    • Near Sunset at Sunset Beach, O'ahu, HI Oct 23, 15
    • Posts 2,621
    • Moderator

    Re: 07 efi won't start only pops out exhaust

    OS - first, welcome to the forums - what part of the country are you from?

    Back to basics, an old fella that used to be here (RIP) once wrote the internal combustion engine only requires three things to run
    - compression (seems lke you got that at 160)
    - measured fuel
    - timed ignition

    You have fuel, but are you geting too much?  there should be specs on your injectors (HD Shop manual?) to test them using an Ohms meter.  I know it is a new pump, . . ., but you might try using a pressure gage to verify it is pumping within spec

    Possibly pull the plugs and connect the wires to them (put the old ones back in as a place holder) and turn it over to visually check the fire.  A friend had the crank sensor go bad on his '97 and I had one go bad on a pick-up (work intermittently).\

    Bob?  Steve?  Bud? anything else?

    The first tool out of the box should be the "book"  Geeked

  • Wed, Apr 25 2018 5:50 AM In reply to

    • FX
    • Top 10 Contributor
      Male
    • Joined on Sun, Mar 12 2006
    • Tonawanda NY
    • Posts 5,174
    • Moderator

    Re: 07 efi won't start only pops out exhaust

    If you are sure the ignition is good, it may be bad coil. You're getting fuel, but no spark to burn it.

    FX

    Don't force it, get a bigger hammer.

  • Wed, Apr 25 2018 9:08 AM In reply to

    Re: 07 efi won't start only pops out exhaust

     sounds like a timing problem to me. coil, crank sensor, faulty ecm come to mind. is it throwing any codes? if i were in the automotive world, i would also suspect that the timing chain or belt could have jumped time. so on this, i would make sure i have lifters pumped up  and that the timing chains are still intact, and push rods are not bent. it's a long shot, but not impossible, that the valves are not opening correctly

     

Page 1 of 1 (4 items)