J&P Cycles Technical Forums

Come participate in our American V-Twin and Metric motorcycle tech forums
Welcome to J&P Cycles Technical Forums Sign in | Join | Help

Search

You searched for the word(s): userid:2189
Page 1 of 11 (110 items) 1 2 3 4 5 Next > ... Last »
  • Re: Xena locks

    I've been using one for a couple of years now. Besides letting you know if someone is f***ing around with your ride, it will also alert you if you try and ride off without taking it off.
    Posted to Harley Tech Talk (Forum) by RandeeReid on Wed, Sep 22 2004
  • Re: Progressive Ins

    I've got my car and three bikes insured with them. I've never had a claim with the bikes, but I had an accident with my car and I called the claims Rep and gave him the info and they took care of everything. I never had to do anything else. Of course my rates went up 'cuz it was my fault, but I've been very satisfied with their customer service. I also keep checking around for cheaper rates, and they still come in the lowest. But that might just be the way it is here in So. Fl.
    Posted to Harley Tech Talk (Forum) by RandeeReid on Fri, Aug 6 2004
  • Re: Reliability & longivity

    Thanks...
    Posted to Sportster Lounge (Forum) by RandeeReid on Fri, Jul 23 2004
  • Reliability & longivity

    I have a '99 1200C w/35k+ miles on it. I do all the scheduled maintanence on it and it's been a great ride, so far. My only worry is that it is my only transportation and I'm concerned about how long I should expect the motor to hold out before needing any serious work done on it. I replaced the clutch last month. Should I expect to get a lot more miles out of it with reasonable care, or should I start looking to replace it before anything goes "south"?
    Posted to Sportster Lounge (Forum) by RandeeReid on Fri, Jul 23 2004
  • Speedometer Erratic

    '99 1200C w/35k miles. At the end of about a 100 mile ride yesterday morning, my speedo quit working for awhile but then started up again but was erratic. Whin I got home I started looking into the sensor as the problem but couldn't get to the bolt that holds in in place. Ya gotta love the MoCo for making things user friendly LOL. Any way, later in the day I needed to go out again and it seemed to work about 95% on the time. This morning it was working but I noticed that whenever I used my turn signals
    Posted to Sportster Lounge (Forum) by RandeeReid on Mon, Jul 12 2004
  • Re: power tube

    I installed the "tube" on my '99 1200C about two years ago and got a noticable increase in performance and a small increase in mpg. I think it works great....
    Posted to Sportster Lounge (Forum) by RandeeReid on Mon, Jun 21 2004
  • Re: Clutch Wear

    Yea...I adjusted it last week and again last night according to the factory manual. I'm running out of cable for the lever adjustment and am bottoming out the clutch inside. I set the spring pressure to manual specs also. It wouldn't completely disengage yesterday so I adjusted the cable again as I needed to ride to work. It's shifting hard right now and neutral is real hard to find. I'm trying to hold out until I can get it to my local indy shop tomorrow.
    Posted to Sportster Lounge (Forum) by RandeeReid on Mon, May 24 2004
  • Clutch Wear

    I've got a '99 1200C with just over 32,000 miles on it. Stage 1 mods only. I've noticed that the last couple of days that I seem to be running out of clutch. Is this normal for the mileage?? I don't abuse the drivetrain but I do ride hard. I'm already planning on replacing the clutch tomorrow.
    Posted to Sportster Lounge (Forum) by RandeeReid on Mon, May 24 2004
  • Re: rain-x on lexan??

    The MoCo makes a product that is applied on a wipe. I don't remember the name but I tried it a couple of years ago and it worked fine...
    Posted to Harley Tech Talk (Forum) by RandeeReid on Mon, May 24 2004
  • Re: engine cleaner

    I agree with War Monger.....Bike Bright w/ S100 .
    Posted to Harley Tech Talk (Forum) by RandeeReid on Fri, Apr 30 2004
Page 1 of 11 (110 items) 1 2 3 4 5 Next > ... Last »